Rimani informato sugli aggiornamenti di SOS-OFFICE. Inserisci il tuo indirizzo e-mail:

Excel: calcolare l'età di una persona conoscendo la data di nascita

Oggi vogliamo vedere come calcolare con Excel l’età di una persona partendo dalla sua data di nascita. La prima cosa da farsi è scoprire quale è il giorno del suo compleanno.

 

Immaginando di avere la data di nascita in A1, per calcolare in B1 la data di nascita, useremo la formula

=DATA(ANNO(OGGI());MESE(A1);GIORNO(A1))

La funzione DATA() crea una data con l’anno, il mese e il giorno che le sono passati (in questo ordine), come argomenti.

L’anno da usare per la data del compleanno lo ricaviamo, con la funzione ANNO(), dalla data corrente che a sua volta otteniamo con la funzione OGGI(). Il mese e il giorno li estraiamo con le funzioni MESE() e GIORNO() a cui passiamo come argomento la data di nascita.

A questo punto possiamo calcolare in C1 gli anni trascorsi fra la data di nascita e la data di oggi con la funzione

=ANNO(OGGI())-ANNO(A1)

Alla cella risultato di questa operazione dovrà essere applicato il formato numero altrimenti Excel la mostra come una data.

In realtà, al numero ricavato dobbiamo togliere 1se la data del compleanno che abbiamo costruito in B1 non è ancora trascorsa o meglio se la data di oggi è precedente alla data del compleanno. Lo facciamo con la funzione che segue

=SE(B1<OGGI();C1;C1-1)

Dove C1 è il numero di anni intercorsi fra l’anno in corso e l’anno di nascita

Anche il risultato di questa formula va formattato come numero generale, altrimenti si presenta come data

Per concludere, se volessimo riassumere tutto in una formula unica, dovremmo scrivere

=SE(DATA(ANNO(OGGI());MESE(A1);GIORNO(A1))<OGGI();ANNO(ADESSO())-ANNO(A1);ANNO(ADESSO())-ANNO(A1)-1)

Commenti   

Paolo
#2 Paolo 2013-11-14 11:06
=DATA(ANNO(A1);MESE(A1);GIORNO(A1))
=SE(DATA(ANNO(A1);MESE(A1);GIORNO(A1))
Citazione
Enrico
#1 Enrico 2013-10-09 10:12
Grazie! :-)
Citazione
Joomla templates by a4joomla